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Welcome to MergeAdmin™

MergeAdmin™ by KEYSTROKE

MergeAdmin merges and imports data from any ASCII data file into an ACT! database
on a field-by-field level

MergeAdmin merges and imports data from any ASCII data file into an ACT! database on a field-
by-field level so you can keep your ACT! data updated with helpful information from other
sources. You determine how to match contacts and which fields to update — all other fields
remain intact.

Take that valuable customer data from around your company and bring it into specific ACT! fields
for each contact — without custom programming. MergeAdmin updates just the ACT! fields you
choose, such as year-to-date sales data, last products purchased, new customer records, data
from web info requests, downloads from the corporate mainframe, billing and credit information
from accounting, and more.



System Requirements

ACT! Minimum System Requirements

Client Installation:

¢ MergeAdmin adheres to the Act! system requirements for your version.

MergeAdmin Requirements

¢ ACT! v18 or higher PRO or Premium

MergeAdmin
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Using MergeAdmin
Getting Started

MergeAdmin is a wizard-based application. In order to start using MergeAdmin, you will launch
the program by going to START > PROGRAMS > KEYSTROKE > MergeAdmin.

NOTE: Help is available throughout the process by clicking the "Quick Help" link on the left-hand
side of the MergeAdmin program window. This will bring up help topics associated with the
current wizard step you are on.

Upon starting MergeAdmin, you will see a prompt with notification of how MergeAdmin handles
field histories.

NOTE: History for field-level changes is only available via ACT!'s field-level history option. This is
not part of MergeAdmin.

MergeAdmin W - Field History x|
Please Mote:
&

History For field level changes is only available via ACT!'s field level
hiskary,

For more infarmation on enabling &CT! field level history, please see
wour ACT! documentation,

[T Do nat show this again.

..................................
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Once you click OK to this prompt, you will be taken to MergeAdmin as seen below:

#» MergeAdmin 3 o ] |
Merge Step 1: Setup
Flease select the ACT! database ko merge inko and the appropriate data source,
File il
1 : ;
1 Mew Configuration ACTI Database
4 open Configuration Select the target ACT! Database:
kd  save Configuration o
Log Yiewer Username: Password:
Help %] Merge Type:
Quick Help &) Contacts \_J) Companies ) Groups
Oriline Help
Suppark Source Data
Web Site

Select the input file:
About Mergaddmin

g [ )
Select the delimiter:

» TCommal ad ] | First row contains column names

| L-Fd

Ready Mo Config

NOTE: If you have previously saved a configuration file, you can open this by clicking "Open
Configuration" from the File drop-down on the left-hand side. For more information on
configuration files, see the configuration file help topic.

Click the Next button to continue to the next screen in the wizard.
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Step 1. Setup

Select the target ACT! Database

You will start the process by selecting which ACT! database you will merge your file into. In
addition, you will need to provide the Username and Password for the database in order to
continue.

Merge Type

From this screen, you will also have the opportunity to select which type of merge you will be
performing. Depending on which radio button is selected, this is where the imported data will be
merged into ACT!.

Source Data

Below is an example of a completed setup screen:

4 MergeAdmin i =10l =]
Merge Step 1: Setup
Flease selectthe ACT! database to merge into and the appropriate data source.
File |
"1 Mew Configuration ACT! Datahase
4 Open Configuration Select the target ACT! Database:
u Save Configuration C:\Documents and Settings\All Users\Documents\ACT\ACT for Windows #\Databases\z | ] ]
Log Yiewer Username: Password:
Chris Huffman Q9
Help il Merge Type:
Quick Help %) Contacts ) Companies ./ Groups
Online Help
Support Source Data
Vieb Site . Select the input file:
About MergeAdmin C:\Documents and Settings\Chris Underwood\Desktop\ASDS Import. b d 0

Select the delimiter:
; fComma} u&a ,i] First row contains column names

Ready Mo Config  Trial processes left: 94

Click the Next button to continue to the next screen in the wizard or click Begin Merge to start
the merge process.
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Step 2. Options

#

Below is an example of the options screen filled out. For information on each item, see below.

i
Merge Step 2: Options
select fromthe general configuration settings below.
File &l
3 New Configuration If a match is found: If a match is NOT found:
& Open Configuration Update Entity HO Add Entity HQ

b save Configuration If multiple matches are found

Log Viewer Update Al {57 ]
Help | vl Create backup

i Save Backup To:
Fireies EdfEE i S C:\Documents and Settings'Chris Underwood My Documents \ASDS
Online Help )

\v| Save merge log

Support r - = i .
Web Site oo iy Bl C:\Documents and Settings'Chris Underwood My Documents \ASDS
About MergeAdmin

\»| Add merged contacts to ASDS.MergeAdmin group
|| Verify merged data matches source data

|  Previous ]I Next Ré

Ready Mo Config @ Trial processes left: 94

"If a match is found": This option sets what happens when a source contact matches a
contact in your database. Here are your choices:

e Add Entity: This option adds the source entity as a new entity in ACT!.

e Prompt for Action: This option prompts you to make a choice during the import process.

e Skip Entity: This option skips the entity entirely, and nothing will be written to the entity
in your database.

e Update Entity: This option updates the entity in your database with the fields you map.

"If a match is NOT found": This option sets what happens when a source contact does not
match a contact you have in your ACT! database. Here are your choices:

e Add Entity: This option adds the source entity as a new entity in ACT!.
e Do not add Entity: This option skips the entity entirely and nothing will be written to the
database.
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e Select Entity: This option gives you a selection tool to choose which entity in ACT! gets
updated.
[ )
"If multiple matches are found": This option sets what happens when more than one source
contact matches one or more contacts in your database. Here are your choices:

e Add Entity: This option adds the source entity as a new entity in ACT!.

e Select Entity: This option gives you a selection tool to choose which entity in ACT! gets
updated.

e Skip Entity: This option skips the entity entirely and nothing will be written to the entity
in your database.

e Update All: This option will update the multiple matching entities with the import field
data.

"Create backup": By checking this box, you can select to make a backup of your data before
the merge process. You need to choose where you would like to save your backup file to.

"Save merge log": This option will create a log file of errors resulting from a problem during
the merge process. You must specify where the log file is saved to. NOTE: You will need to
use the MergeAdmin LogViewer to see the errors. To learn more about the LogViewer,
see the MergeAdmin LogViewer help topic.

"Add merged contacts to KEYSTROKE.MergeAdmin group": This option creates a group in
the ACT! database of all updates and changes that took place during the MergeAdmin process.

"Verify merged data matches source data": By checking this option, during the merge
process the data will be checked against the import file to ensure the data successfully matched
up. NOTE: By checking this option, it can extend the time it will take to complete the
merge.

Click the Next button to continue to the next screen in the wizard or click Begin Merge to start
the merge process.

10
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Step 3. Source Field Preview

This panel shows you a preview of your import data. In previous versions of MergeAdmin, you
were prompted to select your data types for each field. That step is no longer necessary.

i

Step 3: Source Field Preview

Below is a preview of vour source file, Earlier wersions of Mergeddmin required mapping of
field data types during this step, This is no longer required,
File |
1 Mew Configuration Source Preview: (3 of 3 tokal records)

ity State Zip

Address

Zonkack

#  Open Configuration

B Save Configuration (ASDS Camp. ., Chris Under. .. [ 123 Any Str... | Springfield
Pacific WS SaralUnder... 555 HereRd  Springfield R a747a
Log Yiewer
CCM Lee Underw, ., 833 Ower Rd  Springfield 3] 7474
Help ol
Cuick Help
orline Help
Suppork
‘Web Site
About Mergeadriin
| Previous | Mk | Beqin Merge

Ready Mo Config

NOTE: Only the first ten records are shown here.

Click the Next button to continue to the next screen in the wizard or click Begin Merge to start

the merge process.

11
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Step 4. Match Criteria

The next step in the process is selecting the matching criteria that will be used to find a match
between your source file and your ACT! database.

ACT! Field
These are the fields in your ACT! database.

Operator
These are the available operators you can use when linking your ACT! fields to your Source
fields. By clicking the drop-down, you will have access to the various operators listed here.

Source Field
These are the fields in your import file.

Switch to Advanced View

By selecting this button, the match criteria screen will be replaced with a query builder screen to
allow for more advanced matching capabilities. For more information on Advanced View, see the
example below.

Here is an example of the simple match criteria screen filled out. For the advanced matching
criteria view, see the example below.

{) MergeAdmin i ] |
Merge Step 4: Match Critena
“|| Select the criteria you would like to match duplicates on. Notethat if you do notchoose any
criteria, a straight impart will occur with no duplicate matching.
File
" Mew Configuration
= e . ACT! Field Operator Source Field
n Configuration - ;
- i : | Address 1 \ad EqualTo | Address ndl
Save Configuration : ;
u 3 |v]|Contact lad EqualTo lag Contact ad
Log Viewer - - ; ;
< .1] Comparny lad EqualTo lad Company v |
Help (=]
Quick Help
Online Help
Support
Web Site
About MergeAdmin
| Switchto Advanced View J
|  Previous | Mext L\\\J | BeginMerge ]
Ready Mo Config = Trial processes left: 94

12
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Advanced Matching Criteria View

This view allows you to use query-based logic to find your matching criteria. This system is
modeled after the ACT! 2010 query builder system. If you wish to switch back to the basic view,
you can do so by clicking the button that is labeled "Switch to basic view".

1\ MergeAdmin

Help

Mew Configuration
Open Configuration
Save Configuration

Log Viewer

il
Quick Help
Orline Help
Support
Web Site
About MergeAdmin

Ready Mo Config Tnal processes left: 94

Step 4: Match Critena
Select the criteria you would like to match duplicates on. Notethat if you do notchoose any
criteria, a straight import will occur with no duplicate matching.

( ACTIField  Operator  Source Field j ]
[ Address 1 EqualTo Address

Switch to basicview J

| F"_r&\rims ] | NM%J | EieEinMe.lggJ ll

Click the Next button to continue to the next screen in the wizard or click Begin Merge to start
the merge process.

13
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Step 5. Map Fields

During this process, you will map the fields from the incoming source file to the fields that are
already in your ACT! database. See the completed example of this screen filled out below:

4» MergeAdmin = ID[lI
M Step 5: Map Fields
Match the ACT! fields belowto the apropriate source field onthe right.
File a
“{  Mew Configuration ACT! Field |Replace ACT!Data  Source Field | Import Source Data had
.#) Open Configuration ~ Company Always Company Always
L) save Confiuration —I Contact Always Contact Always
Address 1 Always Address Always
Log Viewer =
& iEEtE Always State Always
| Help ﬂ| |ZLP Code Always Zip Always
i L I
Quick Help » I | . -
Online Help
Support
Web Site
About MergeAdmin
s

| Previows | [ Next | | Lﬁgﬁmﬂm

Ready NoConfig | Tral procesesef: 94

14
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ACT! 2010 Field - These are your fields that already exist in the ACT! database. You also have
the following options under the ACT! Field column:

e Add Note - By choosing this from the drop-down list, the data from your source will be
created as an ACT! Note.

e Add History - By choosing this from the drop-down list, the data from your source will
be created as an ACT! History.

¢ New Field Button - By clicking this button, you can create a new field in your ACT!
database to map your source data into. See the example below:

¢ Create New ACT! Field

Figld Mame
|;’-‘u:|:u:uunt Mumber |

Field Type

|Charac1er v|

Cancel QK

15
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Replace ACT! Data - This choice is used to set whether the data coming in will "Always" replace
the existing data or "Only if Empty," meaning there is no data in the ACT! fields.

Source Field - These are the fields that are in your import file. You also have the following
options under the Source Field column:

e Merge Fields - This function will give you the ability to merge two or more source fields
into one ACT! field. See the example below:

i Merge Fields
Map these fields
Source Figlds: Separate by:
City - R
State b X
oK Cancel

-

Import Source Data - This choice is used to set whether the source data is "Always" imported
or "Non-Empty Only" meaning the import data must contain data or it will NOT be imported.

Click the Next button to continue to the next screen in the wizard or click Begin Merge to start
the merge process

16
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Step 6. Summary

This screen shows you all the options that have been set throughout the MergeAdmin wizard.
This is your final chance to review these settings before clicking Begin Merge to start the
process. If any changes are needed, you must click the Previous button to navigate backward
through the wizard until you reach the desired step. When clicking Begin Merge, you will be
presented with an option to save your changes as a configuration file. At this time, you can
choose "Yes" and create a configuration file with your settings to be used for future imports
using the same settings. See the example below of the Summary screen.

i
Merge Step b6: Summary

¥ou have now completed the A3DS. MergeAdmin 2008 wizard, Review the information below
for accuracy and press "Begin Merge" when wvou are satisfied.

File il
"1 Mew Configuration Merge Type: Contacts
4  Open Configuration ACT! Database: C:\Documents and Settings\All Users\Documents\ACT\ACT for
u Save Configuration Windows ‘Databases\act®demo.pad
Log Viewer Import File: C:\Documents and Settings\Chris Underwood\D esktoplASDS
Import.txt
Help kel
Quick Help Create Backup: True
Online Help Save Log File: True
Support
Create Merge Groups: True
Web Site -
about MergeAdmin Venify Merged Data: True
Match Critena: {Aaddress 1 EqualTo Address) Or

{Contact EqualTo Contact)

_BeginMerce

| Previous

Ready Mo Config = Trial processes left: 94

Click Begin Merge to start the merge process.

17
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Configuration Files

Configuration files are used to store previously saved settings such as the database info, mapping
details, etc. If you are importing files from the same source on a regular basis, you can speed up
the process by saving your configurations. This eliminates having to repeatedly fill out the
database information, source file locations etc. To use configuration files, use the steps below:

1. Go through the MergeAdmin wizard and fill out the fields accordingly.
2. Click Save Configuration from the "File" area on the left-hand side of the window.
3. Give your configuration file a name and click the Save button.
From the "File" area in MergeAdmin, you can do the following:
e Create a New Configuration

e Open a Configuration
e Save a Configuration

18
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MergeAdmin

Here is an example of the "Prompt for Action" dialog box when the source entity already exists in
your ACT! database. You have the following options:

e To update the ACT! entity, select the row that matches the source record and click the

Update button.

e To add the source entity, disregarding the match criteria, click the Add button.
e To skip the source entity, disregarding the match criteria, click the Skip button.

Existing Record

€1 Contact already exists. Update contact. add contact or skip contact?

ACT! Data Import Data
Field Value Public =
| { : Chris Huffman
Company CH Gourmet Gifts CH Gourmet Gifts
Fullname Ernst Anderson Cecil Carter
Firstname Ernst 13 East Bdth St
Lastname Anderson
Email Mew York
NY
Phone 10034
United States
Address 1 Coworker
Address 2 212-505-7323
. 212-555-7750
City
State
Postal Code Cacil
Last Edit 4/9/2007 2:01:49 PM 7/5/2002 r
| updae || add || s |
Previous versions of MergeAdmin used the below dialog.
€] Existing Contact
Contact already exists. Update contact, add contact or skip contact?
Field WValue o~
‘Record Creator |Chris
Last Edited By ;{:hris Huffman |
Record Manager :Chris Huffman |
IsUser |User [
Home State (MY
Home Country iL.Inited States !
Last Reach 313/2005 5:30:00 AM |

19
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Select Entity Dialog

Here is an example of the "Select Entity" dialog box. At the top of this box is the source record
from your import file. The list below will show you the entities in your ACT! database that

matches your selected criteria.

e To update the ACT! entity, select the row that matches the source record and click the
Update button.
To add the source entity, disregarding the match criteria, click the Add button.
To skip the source entity, disregarding the match criteria, click the Skip button.

81 Select Contact

[* Based onyour matching criteria, the following contact already exists in your database.

Source Record:
Public/Private: Public
Record Manager:  Chris Huffman
Company: CH Gourmet Gifts
Contact: Jane Chan
Address 1: 13 East 54th St
City: Mew York
State: MY
zZip: 10034 %
———————————————————————————————————————————————————

[ Select a row belowto update with the Source Record above, then click Update. Click Add to create a new record based on the above source,

ACT! Records:
Company First Mame Last Mame E-mail Fhone Address 1 Address 2 City ZIP Code
I [ et N S R
CH Gourmet Gifts Cedil Carter
X i ———— kd
e e ][50 ]

20
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Previous versions of MergeAdmin used the below dialog.

€ Select Contact N

[§> Based on your matching critena the following record could not be located.

Source Record:

[Name:  Jeremy Underwood
Phone:  BR&-ZZ2-0111
Address: \west First Drive
City: Salem

State: Oregon

ACT! Records:

Home State | Home Cou.. | Referred By | Web Site Pager Exte . | Spouse A
4 7 | [ |

OR United States |Advertisem.. |[www Jawso.. Mary Jo C
www chgou.. e
< i > il
Skip Add Update

21
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MergeAdmin LogViewer

How To Use The MergeAdmin LogViewer

The MergeAdmin LogViewer is the tool that is used to see the error logs that are created if you
have enabled this option. In addition, the error log will allow you to make changes to the data
that failed and re-export just the fixed data out as a new file. You can then re-import this fixed
file instead of having to re-import your entire file.

You can launch the log viewer from START > PROGRAMS > KEYSTROKE > MERGEADMIN
> MergeAdmin LogViewer. You can also click "LogViewer" from the "File" area on the
MergeAdmin program window. Once the MergeAdmin LogViewer is launched, go to FILE > OPEN
and browse to the location you saved your log files to.

Below is a screenshot of the LogViewer.

& MergeAdmin LogViewer |z] |E| E|

owSkipped | Public/Priv.. | Record M.. | Company

I§tatus Ready...

In the example above, companies were mapped to ACT! from the source file, however, the
entities above did NOT contain a company name; therefore they were excluded from the merge
process.

22
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As shown in the example below, you can enter a company hame on these records right from the
LogViewer and then re-export those back out as a new source file by going to FILE > EXPORT
SKIPPED ROWS. See the example below for this dialog box.

& MergeAdmin LogViewer

QOpen Log Ctrl+0

Print Log Ctrl+pP
Ctrl+5
Ctri+C

Save Log

Mohlame Address_2

FRichard Bays (5316 G St iSpmnl

Address_3 (-:F

Closelog

Export Skipped Rows thrI+E
Export All Rows Ctrl+a,

Ctrl+x

IEatus Ready... g

23
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Automating MergeAdmin

Users who wish to bring in files unattended at night or multiple times per day can use
our product.

AutoAdmin automatically imports in ACT! using the MergeAdmin software. By using MergeAdmin
to set up an import, you can set AutoAdmin to automatically launch and execute your saved
MergeAdmin configuration. See the steps below:

1. You must first use MergeAdmin to set all of the parameters of the import and then save
the configuration using the save option in MergeAdmin.

2. Create a new timeslot in AutoAdmin following the steps found in this help file.
Under the “Misc” tab, select the option for “Launch MergeAdmin using config:”

4. Press the button to browse to where you saved your MergeAdmin config file and choose
Open.

5. Click the Apply button to save the changes.

Trial Ware Information

Trial Ware Information

MergeAdmin comes with a 30-day trial that is limited to a 500 contact import. When you launch
MergeAdmin you will be prompted to try the program or register. You can utilize your 30-day trial
by simply clicking the "Try' button. If you have purchased the software, you can choose the
'Register' button and continue through the process by activating your software. See the example
below:

24
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Registration

Registration

When you choose to register your product, you will be prompted to input your information as
shown below. You must fill out the fields marked with a red circle. Upon entering this
information, you will choose the 'Register' button to continue on to activation.

W MergeAdmin

Register Your Software

[,
% To unlock the full capabilities of MergeAdmin | you must register,
“ otherwise you can continug in trial mode to evaluate the software.

Indicates that you must fill in the field.

((Regise ] [ In |
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Activation

Activation

Once you have entered your information on the 'Register Your Software' window, you will be
prompted to Activate Your Software. See the example below:

Activate Your Software

ﬂl In order to continue you must activate your license. Activation verifies
ﬁ that you are using a fully licensed version of MergeAdmin and are
eligible for updates and support.

(5] Activaie onk S -
{5 oF Iy i Activate online now. Requires an active Internet connection.
remaining

i Ml - fouvat monvely by enerngacode |

() Activate Later .

15 of 15 days remaining to ac lergefdmin . If you do not complete
me ures may not work unti complete activation.

WARNING: Activating your license on this machine may prevent you frominstalling the software
on additional machines. Please consult your licensing agreement for license usage and restrictions
before continuing.

) Tell me more sbout Activation.

26
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Once you choose 'Activate online now', you will see the following box to show it was successful.

& Mergehdmin D =)

Success. Select OK to continue.

Note: When you activate your software, it can ONLY be used on the machine in
which it was activated on. If you choose to install it on another machine, you MUST
'Deactivate’ the software first and then 'Activate’ it on the new machine.

27
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Troubleshooting
Frequently Asked Questions

Question:
How do you launch the application?

Answer:
MergeAdmin is loaded by going to Start > Programs > KEYSTROKE > MergeAdmin >

Question:
When trying to create a new configuration file nothing happens.

Answer:

This will be the case when you have not loaded a previous configuration file first. If the fields in
the wizard are already blank, you are already on a new configuration. If you have a
configuration loaded and the fields are filled out, going to File > New Configuration should
blank them out to allow you to create a new one. You would then go to File > Save
Configuration once you have completed the wizard.

Question:
What if I need to reinstall, will I have to re-register?

Answer:

You should not need to re-register the software as long as you have NOT deleted the program
directory. Your registration is saved even after an un-install. However, if you manually delete the
program directory or do a reformat of your machine, the registration will be lost and you will
need to contact us for a replacement registration.

28
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Technical Support
Contact Us

Technical support is available by visiting the KEYSTROKE support site. We offer several services
to meet your technical support needs. Please visit us today @ www.Keystroke.ca/support to see
if there are any known issues with your product.

Please note: We only support issues or errors with the MergeAdmin software itself.
Any troubleshooting of import files, helping with the setup of map configurations,
etc. are subject to our current billable rate.
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